Sunday, April 29, 2012

Solusi Paket Tidak Bisa Di Autentikasi Pada Ubuntu



Pernahkah Anda mengalami masalah ketika mau menginstall Aplikasi muncul tulisan WARNING: The following packages cannot be authenticated! . Memang meski muncul pesan WARNING aplikasi tetap bisa di install tapi terlihat cukup mengganggu. Munculnya WARNING tersebut karena gpg-key nya bermasalah, belum terupdate atau bahkan belum terpasang. Untuk mengatasinya berikut solusinya:



Coba update keynya terlebih dahulu menggunakan perintah ini
sudo apt-key update

Akan muncul seperti ini

gpg: key 437D05B5: "Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>" not changed
gpg: key FBB75451: "Ubuntu CD Image Automatic Signing Key <cdimage@ubuntu.com>" not changed
gpg:  Total number processed: 2
gpg:              unchanged: 2

Coba kembali melakukan perintah instalasi aplikasi lagi jika masih muncul tulisan WARNING berarti gpg key-nya bermasalah. Hapus gpg key tersebut kemudian update kembali, untuk menghapusnya gunakan perintah :

sudo apt-key remove 437D05B5 && sudo apt-key remove FBB75451



Sekarang jalankan perintah update
sudo apt-key update


Jika muncul seperti ini

gpg: key 437D05B5: public key "Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>" imported
gpg: key FBB75451: public key "Ubuntu CD Image Automatic Signing Key <cdimage@ubuntu.com>" imported
gpg: Total number processed: 2
gpg:               imported: 2
gpg: no ultimately trusted keys found

Bearti gpg key telah di perbaharui sekarang lakukan update paket

sudo apt-get update


Sekarang coba lakukan perintah instalasi aplikasi lagi jika tidak muncul tulisan WARNING berarti telah berhasil. Jika menemukan masalah silakan tinggalkan komentar dibawah ini

Selamat Mencoba :D

1 comment:

  1. Kalau untuk yang Offline,Bagaimana???

    ReplyDelete